2015 with THX audio issues - Page 2 - Lincoln MKC Forum
 6Likes
Reply
 
LinkBack Thread Tools
post #11 of 16 Old 11-14-2019, 07:30 PM
Senior Member
 
Join Date: Aug 2015
Location: Near Chicago IL
Posts: 713
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)
It looks like the amp is stored in the center dash not in the rear hatch as I thought. Confused with my former Ford Edge.

2016 MKC - August 2015 build
Platinum White - Wht Sands/Espresso
Reserve 300 AWD
2.3 Ecoboost
Sync 3
20" Wheels
Technology Package
Climate Package
All Weather Floor Mats
Premium Reversible Cargo Mat
blankster is online now  
post #12 of 16 Old 11-19-2019, 09:01 AM
Junior Member
 
Bluebird88's Avatar
 
Join Date: Jan 2018
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thank you I have ordered a new amp from them hopefully this will fix the problem
Bluebird88 is offline  
post #13 of 16 Old 11-20-2019, 10:55 AM
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by blankster View Post
The thx amps for the 2015 models were problematic. The amp is located in the rear hatch left side (I think). You may find a place that repairs them or exchanges your amp for a remanufactured one. I see on eBay there are some amps for sale but I’m not sure if they are the thx version. Use google you may find one that way. I see Tascaparts.com has it for $336. I’ve bought from them in the past with no issues.
I tried to buy from them, but they also want a core charge till you send back the old amp to them. I got mine off eBay from a ford dealer. I got it for the same price, but after i installed it, it didn't work for all speakers. had to go to ford for them to update the system and reset it. works great now. cost about $100+/- for them to reprogram.
Cram is offline  
 
post #14 of 16 Old 12-08-2019, 01:14 PM
Super Moderator
 
Join Date: Jun 2014
Location: Upstate, NY
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Garage
My 2015 with THX has also just started developing this problem. Any idea how to access the amplifier? Do I got to take the whole dash apart?
kdawg is offline  
post #15 of 16 Old 12-08-2019, 05:45 PM
Senior Member
 
Join Date: Aug 2015
Location: Near Chicago IL
Posts: 713
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)
The amplifier is in the center of the dash. Google the part and you will see a partial diagram.

2016 MKC - August 2015 build
Platinum White - Wht Sands/Espresso
Reserve 300 AWD
2.3 Ecoboost
Sync 3
20" Wheels
Technology Package
Climate Package
All Weather Floor Mats
Premium Reversible Cargo Mat
blankster is online now  
post #16 of 16 Old Today, 01:53 PM
Member
 
Join Date: Jun 2017
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Quote:
Originally Posted by blankster View Post
The amplifier is in the center of the dash. Google the part and you will see a partial diagram.
I'm not sure this is correct. If you fold down the rear seats and lift up the "flap" on the drivers side, you'll see the Amp sitting right there (on THX models anyway). I was running the system hard one day and when I turned the car off, I kept hearing fans running. I traced it there and there is a huge amp sitting there.
joebrez is online now  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome