2015 with THX audio issues - Lincoln MKC Forum
 6Likes
Reply
 
LinkBack Thread Tools
post #1 of 16 Old 02-23-2019, 01:28 PM Thread Starter
Member
 
manninp's Avatar
 
Join Date: Apr 2018
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
(Thread Starter)
2015 with THX audio issues

I have a 2015 MKC with THX sound and today out of nowhere the sound system is all messed up. Front speakers don't seem to be working, and it's tinny and extra bassy even when bass turned way down. Was absolutely fine when I parked it last night. Started it today and just sounds like garbage.

Thoughts?
manninp is offline  
post #2 of 16 Old 02-23-2019, 05:01 PM
Member
 
SubVette's Avatar
 
Join Date: Nov 2018
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Send a message via AIM to SubVette Send a message via MSN to SubVette Send a message via Yahoo to SubVette
Dealer.......
symetry and jcbon like this.

2019 Lincoln MKC Reserve
MKC Climate Package
MKC Technology Package

Enhanced THX II Certified Audio System
19-inch Machined Aluminum Wheels with Premium Painted Pockets
SubVette is offline  
post #3 of 16 Old 02-27-2019, 09:24 PM
Junior Member
 
Join Date: Oct 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's the amplifier. In the back under the spare tire. Thank goodness mine was still under warranty. It's like 600-800 dollar part. It took the garage a week to figure it out. They said that's prob what it was but had to rule out everything else. Mine cut in and out for about a month before going to just the small sound all the time
symetry, copbait and SubVette like this.
Cbtlab is offline  
 
post #4 of 16 Old 09-29-2019, 06:23 PM
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
My 2015 just started doing the same thing. Front speakers go out back is very quite. Do i need a dealership to replace or can I do this on my own. Is the amplifier also the brain for the screen?
Cram is offline  
post #5 of 16 Old 09-30-2019, 09:54 AM
Senior Member
 
Join Date: Jun 2014
Location: North Georgia
Posts: 160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by Cram View Post
My 2015 just started doing the same thing. Front speakers go out back is very quite. Do i need a dealership to replace or can I do this on my own. Is the amplifier also the brain for the screen?
I have to assume that it is the amplifier going out. Mine went out about 5 months ago, exactly the same symptoms, Mine is a 2015 MKC built/purchased roughly August 2014. Since I was outside the 48 Month/50,000 warranty, I was quoted a price of $1,041 parts and labor for the replacement.

I questioned the service manager on if he could do anything for me on that. Apparently, he went to bat for me, since he got it covered as a warranty service. I honestly did not ask questions on exactly how he got that done since I was 6+ months out of warranty. I was just happy not to be spending $1K.

I don't believe it is the "brain" of the system since nothing else was affected by the amp going bad. Just cutting out of the front speakers.
Cram likes this.
KenZ is online now  
post #6 of 16 Old 09-30-2019, 09:56 AM
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks,

I'll just order a new one and see if this fixes my sound issues.
Cram is offline  
post #7 of 16 Old 09-30-2019, 04:15 PM
Senior Member
 
Buckeye's Avatar
 
Join Date: Jun 2018
Location: Ohio
Posts: 129
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Garage
It would be nice if someone could open it up and look for bad solder points.
https://www.f150forum.com/f75/how-fi...808-aa-227544/
My neighbor's GM had a part go bad.. A little bit of googling and 10 minutes of soldering I saved him about 400 bucks plus labor. Looks like it could be an option here.
VW used to make an alternator that would go bad. it was $1000 alternator that had a 50 cent part that would go bad inside it. If someone was slightly handy they could fix it.

2017 Burgundy MKC AWD Reserve 2.3L 20" rims, Tech Package, Climate Package,
Buckeye is online now  
post #8 of 16 Old 09-30-2019, 04:26 PM
Senior Member
 
Buckeye's Avatar
 
Join Date: Jun 2018
Location: Ohio
Posts: 129
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Garage
from some other forum. I take no credit.
Quote:
To repair any of the MXK Amplifiers un-mount it from the plate tap the back of the amplifier with the radio on see if it starts or stops the tapping or thumping sound if it does, then turn off the car, remove the amp, take the cover off, re-solder all the connectors, the power transistors, anything with large leads that have not had complete solder thru the board, re-solder the larger capacitors, look at the back plate where the dimples contact the board. If the dimples wore thru the gold foil contacts cover the wear marks or holes/scratches with solder. Take small flat file and clean the top of the dimples on the metal case, clean the metal screw wells on the case. Clean all the screw holes on the printed circuit board with emery cloth or an abrasive eraser. Also solder the little power transistor heat sinks. Leave the rest of the chips/ power amps alone. Reassemble reconnect, turn on it will not come on right away since it has to re-sync. Give it 3-5 minutes if you did not make any solder bridges you should be hearing THX sound at this time... Run the THX demo doesn't it sound great?

Model numbers are:
8L7T-18B849-AC
8L7T-18B849-AD
8L7T-18B849-AE

2017 Burgundy MKC AWD Reserve 2.3L 20" rims, Tech Package, Climate Package,
Buckeye is online now  
post #9 of 16 Old 11-14-2019, 06:09 AM
Junior Member
 
Bluebird88's Avatar
 
Join Date: Jan 2018
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a 2015 MKC with the same problem first the front speakers stopped working the rear ones then also failed and crackle even when radio is not turned on the problem has now escalated to my battery keeps going flat so I can’t drive it at all I am in the U.K. and there are no Lincoln dealerships here I am having trouble getting my car fixed I spoke to Lincoln who referred me to Ford U.K. they referred me to a Ford dealership I booked it in and they phoned to say they didn’t know how to get the door panels off so I told them to leave it I finally got a car electrician to look at it he says it is the amp. I will have to get amp shipped to the U.K. which is going to be expensive can anyone tell me what part I need please?
Finally I would not recommend owning a new Lincoln in the U.K. as there is absolutely no back up from Ford here it’s a shame because it is a lovely car
Bluebird88 is offline  
post #10 of 16 Old 11-14-2019, 07:16 PM
Senior Member
 
Join Date: Aug 2015
Location: Near Chicago IL
Posts: 713
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)
The thx amps for the 2015 models were problematic. The amp is located in the rear hatch left side (I think). You may find a place that repairs them or exchanges your amp for a remanufactured one. I see on eBay there are some amps for sale but I’m not sure if they are the thx version. Use google you may find one that way. I see Tascaparts.com has it for $336. I’ve bought from them in the past with no issues.

2016 MKC - August 2015 build
Platinum White - Wht Sands/Espresso
Reserve 300 AWD
2.3 Ecoboost
Sync 3
20" Wheels
Technology Package
Climate Package
All Weather Floor Mats
Premium Reversible Cargo Mat

Last edited by blankster; 11-14-2019 at 07:22 PM.
blankster is online now  
Sponsored Links
Advertisement
 
Reply

User Tag List




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome