New guy here. Need help asap. - Lincoln MKC Forum
 
LinkBack Thread Tools
post #1 of 4 Old 02-10-2019, 01:36 AM Thread Starter
Junior Member
 
Remy Cameron's Avatar
 
Join Date: Feb 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
New guy here. Need help asap.

Hello friends. I’ve owned my 2015 Lincoln MKC for about a year now. And recently I had issues with the electrical components. I’ve since fixed that (broken plug-in by left foot side was causing weird flashing lights and failed steering column). But now, I just got off the highway and was waiting at a red light, and when it turned green I went to push the gas and it made a “chugga chugga chugga” before the car shut off. Electrical components and lights are all fine. I couldn’t restart the car. It was a nightmare smh holding up 5 o clock traffic on the busiest street in my city. I pushed it about 50 ft out of the way and left it because it wouldn’t start still. Came back an hour later to call AAA and when I tried starting it, it started. I drove it up the street to my aunts because I couldn’t risk the 20 minute highway ride home. I parked and went to adjust the car to the parking spot and poof, same thing as earlier. Every time I stop too long it did it. Now it’s off again. Idk what to do 🏾,🏾. I know mechanical diagnostics is not as simple as just hearing about it and telling me. But if anyone has had a similar issue and can at least tell me what it was it would be helpful. Thank you in advance for the help and input guys.
Remy Cameron is offline  
post #2 of 4 Old 02-10-2019, 01:39 AM Thread Starter
Junior Member
 
Remy Cameron's Avatar
 
Join Date: Feb 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Btw, the check engine light is the only one on. And also I do not need an oil change or gas. But, oddly yesterday when I put hasn’t in at 22 miles left, the only thing that changed was the actual blue gas bar telling me it was at a quarter tank. The amount of miles stayed at 22 and went down to zero and stayed there even though I had more than 40 miles left (estimate, I know my car well enough to guess that much )
Remy Cameron is offline  
post #3 of 4 Old 02-10-2019, 07:14 AM
Senior Member
 
Buckeye's Avatar
 
Join Date: Jun 2018
Location: Ohio
Posts: 105
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Garage
I was going to say bad fuel pump or clogged one, but it looks like you're leaning that way. Not uncommon for them to go bad.
With my Continental.... I got out of my driveway and the car just died. I had it towed and Lincoln replaced the pump. I never thought something like that should go bad so quickly but it appeared it was not uncommon.

In a general sense... engines die for one of two reasons: 1) lack of gas or 2) lack of spark.
I am unsure if you call Lincoln if they can remotely go in and see what they find in error codes. I know my 2017 they can.
Since the CEL was on - take it in to an auto parts place. they tend to have the tool (OBDII reader) to read the code. (all free typically)

or take it in and ask them to test out the fuel pump and any electrical systems as a part of the engine.

Good Luck

2017 Burgundy MKC AWD Reserve 2.3L 20" rims, Tech Package, Climate Package,
Buckeye is online now  
 
post #4 of 4 Old 02-10-2019, 11:59 AM
Senior Member
 
countryguy's Avatar
 
Join Date: Nov 2015
Location: Astorville, ON Canada
Posts: 625
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 163 Post(s)
There is a TSB for the fuel sensor on some 2015 MKCs (mine was one of them). The gas gauge would not read accurately. Perhaps there is a problem with the fuel pump?

2015 MKC
2.3L AWD
White Platinum Met Tri-Coat/White Sand Prem Lthr
Equip. Group 102A Reserve
Climate package
Technology package
20" aluminum wheels
Build 12/2014
Lease end 06/23/19 - car returned to Lincoln
countryguy is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome