Retained Accessory Power - Page 3 - Lincoln MKC Forum
 10Likes
Reply
 
LinkBack Thread Tools
post #21 of 22 Old 07-15-2019, 10:22 AM
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
My 2017 MKC has now been in the shop six times with a dead battery. Lincoln seems to have no clue how to fix it or that they even have a systemic problem. They have replaced the instrument cluster, the battery, module replacements, applied various updates and most recently the gateway module. Each time they assure me the problem has been fixed. This trip (two months since my last visit) the vehicle has been in the shop 10 days - awaiting the "rush delivery" of the part - I repeat 10 days for the rushed the delivery of the module. I am told the part will arrive today, a day or two to install, they'll keep it for a day or two to test. They will send me home with it saying it is fixed, not really knowing and I expect to be back in 2-4 months with a dead battery, unless it dies right in the shop as it did earlier this week

What also bothers me is they seem to be unable to piece the various other items I tell them, which I believe are all related, but they just hook it up to a computer and do what it says - interestingly it comes up with a different reason each time. The Lincoln app works off and on (it does months without talking to their server, but I think it continues to try), the welcome lighting no longer works, the car does not automatically unlock when you grab the handle - but they ignore all these other issues.

It is getting close to lawyer time.
feobrien is offline  
post #22 of 22 Old 07-17-2019, 08:29 PM
Senior Member
 
Join Date: May 2015
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Quote:
Originally Posted by feobrien View Post
My 2017 MKC has now been in the shop six times with a dead battery. Lincoln seems to have no clue how to fix it or that they even have a systemic problem. They have replaced the instrument cluster, the battery, module replacements, applied various updates and most recently the gateway module. Each time they assure me the problem has been fixed. This trip (two months since my last visit) the vehicle has been in the shop 10 days - awaiting the "rush delivery" of the part - I repeat 10 days for the rushed the delivery of the module. I am told the part will arrive today, a day or two to install, they'll keep it for a day or two to test. They will send me home with it saying it is fixed, not really knowing and I expect to be back in 2-4 months with a dead battery, unless it dies right in the shop as it did earlier this week

What also bothers me is they seem to be unable to piece the various other items I tell them, which I believe are all related, but they just hook it up to a computer and do what it says - interestingly it comes up with a different reason each time. The Lincoln app works off and on (it does months without talking to their server, but I think it continues to try), the welcome lighting no longer works, the car does not automatically unlock when you grab the handle - but they ignore all these other issues.

It is getting close to lawyer time.
I would not wait any longer, contact an attorney now...It is best to be proactive, and based on what you've written there is little expectation to have it working correctly. Create a case with Ford/Lincoln to show that you have tried, in good faith to resolve this. If you can show at least 4 attempts or out of service for more than 30 days, you will have a better chance at success. I'd also recommend contacting the BBB.
Buckeye likes this.

2015 MSM is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome