Lincoln MKC Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My car appears to go into what is described by other MKC owners as limp mode. A problem they are well aware of. As I’m driving it literally loses power on the highway going from 70 mph to 10 mph in seconds. I am in danger to get off of the road out of highway traffic. 7 times in 1.5 years and Lincoln says it isn’t registering on the computer so they send me on my way. I’ve taken it to 3 different dealers over this time. Any thoughts?
 

·
Registered
Joined
·
147 Posts
Typically limp mode is associated with engine or transmission.
You can pick up an Bluetooth obdII reader and use the app Torque Pro
you can google more videos. This can help you diagnose and give an INDEPENDENT mechanic enough info to get it fixed.

or plan B Not very helpful here but---- sell it to carmax or something like that and pick up something newer or something else.

other video
 

·
Registered
Joined
·
75 Posts
I had this happen once. Subaru Outback sat at the airport for a few weeks. Drove it about 5 miles and stopped to eat then when we started again it went into limp mode. It was a Sunday in a small town and nothing was open and we were 80 miles from home. I took a chance and disconnected the battery for a few minutes and it cleared the fault and it never recurred. Of course I did some research and the most likely culprit was a bit of moisture in the fuel from condensation which triggered the computer to put it in limp mode. Since I could not get it to duplicate it is anybody's guess to what actually caused it.
 
1 - 3 of 3 Posts
Top