Lincoln MKC Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Less than a month old already getting service. None of the controls below touch screen are illuminated or working. Can not control radio power on/off, volume, no air, no heat-also can't be controlled thru the touch screen using the "climate" tab. Don't think passenger airbag is working since nothing is illuminated indicating its on or off. Nothing. Nada.

All was working fine (for 3 weeks) then I went to start car and saw what you see in picture I attached. Went straight to dealer and while standing outside car while it was running, a very strong smell of something burning...smelled exactly like paper burning. Saw no smoke and it did dissipate. Left it there overnight as it was after service hours. Of course the following day (today) service "couldn't duplicate the problem". They informed me they did a "hard reset" on my modem..found "no errors" soooo fixed right? Wrong! I go pick it up, start the engine and there's the issue-again.

Long story not so short, the car is still there. Srvc said they've never seen it before AND there is no errors being reported when they do whatever it is they do to try to figure these things out. This doesn't sound so good.

Hopefully I will have answers TUESDAY when everyone returns from the long weekend. :(

Well, I was enjoying the MKC until yesterday. I'll update when I know more.
 

Attachments

·
Registered
Joined
·
881 Posts
This happened to me early on, like within a 2 week period.....took it to the dealer,they disconnected the battery waited 10 seconds, reattached it and everything was fine to this day....some kinda glitch,disconnect the battery and reattach and see what happens.... best of luck!
 

·
Registered
Joined
·
644 Posts
Sounds like even with the 2017 models, Lincoln has not fixed the electrical/computer problems that exist with this model....kind of scary to know that 2 model years later and still these problems exist.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Sounds like even with the 2017 models, Lincoln has not fixed the electrical/computer problems that exist with this model....kind of scary to know that 2 model years later and still these problems exist.
Yes, this is scary. Not only is it an inconvenience, but I'm thinking a safety issue as well. I don't think the passenger airbag will work (god for bid) since that is not illuminated either.

I leased this vehicle in the beginning of June. Beginning to wonder if I can get out of it or trade for another that isn't broken :grin

We'll see what Tuesday brings.
 

·
Registered
Joined
·
644 Posts
I hope that you will get some positive results when you bring it in.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
For anyone interested, service replaced a "Pin connector" located in the passenger front foot area. Haven't had the problem since.
 

·
Registered
Joined
·
644 Posts
Yes...glad to hear that it was a minor issue to resolve.
 

·
Registered
Joined
·
644 Posts
Ok.....an easy fix but a difficult problem to find....much like computer bugs in many cases :)
 
  • Like
Reactions: 2015 MSM

·
Registered
Joined
·
239 Posts
Just curious, and I know it's probably a silly question, but with the disconnection of the battery, is it the positive connection or the negative? Also, do you start the car first so it is running when you disconnect? And I seem to remember another post where they said the headlights need to be "on" too...
 
1 - 12 of 12 Posts
Top