Lincoln MKC Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have been trying to get this fixed since I bought the vehicle!

I get in, close the door and fasten the seat belt. The interior lights come on as they should. When I push the start button the lights flash off for a second, then flash back on, then fade out. If I pause for 5+ seconds before starting the engine, the lights will SOMETIMES stay lit and then fade out (which is what they SHOULD do). Other times they flick off, on, fade again.

I had it at the dealer and he claims they called their internal helpdesk and was told "This is due to load on the system and is normal operation. Just wait 5-10 seconds before starting and the lights will work normally." So they are suggesting that the electronics / computer is overloaded when you first get in so it flips the lights off? I dunno... I think I call BS. I have tried many other Ford / Lincoln vehicles and they act normally. They light stays on then fades out. The service manager says "O, the MKc uses different modules." More BS I'm sure. There's no way the MKc module(s) involved are differant than a Escape, or a Fusion or whatever. But I'm not sure how to argue this with them!

Does anyone else have this problem? Anyone been able to fix it?

Thanks all!
 

·
Registered
Joined
·
65 Posts
Mine does not do as you describe. It works as you suggest it should.
 

·
Registered
Joined
·
881 Posts

·
Registered
Joined
·
24 Posts
Mine work correctly but you shouldn't have to WAIT 5-10 seconds before you start your car in order for things to work as they should.

Obviously something IS WRONG if you have to wait, sing a song, clap your hands, stand on your head or any other ridiculous thing they suggest other than getting in and starting your car....like the rest of us.

Good luck to you. My 2017 I got in June is going back in for service next week for the 4th time.
 
1 - 4 of 4 Posts
Top