Lincoln MKC Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
When I log into my Lincoln account online and check for updates, it says I have the latest Sync Version (3.7) but I've seen others have 3.8 and maybe newer. What's the deal?
 

·
Registered
Joined
·
69 Posts
To the best of my knowledge, the latest version is 3.0.
 

·
Registered
Joined
·
733 Posts
3.0 is for Sync 3 for 2016 MKCs or newer. The 2015 uses a different platform (Old Sync) and has separate releases. The "old" Sync may have newer releases available but the rollout is usually by vehicle meaning Release 3.8 may be available on Mustangs but MKC may be later.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
3.0 is for Sync 3 for 2016 MKCs or newer. The 2015 uses a different platform (Old Sync) and has separate releases. The "old" Sync may have newer releases available but the rollout is usually by vehicle meaning Release 3.8 may be available on Mustangs but MKC may be later.
Gotcha, thank you!
 
1 - 4 of 4 Posts
Top