Lincoln MKC Forum banner
1 - 6 of 6 Posts

Registered
Joined
7 Posts
Discussion Starter · #1 ·
Pardon me if this has already been discussed I tried weeding through the vast amount of information already. I have a 2016 MKC Reserve with an embedded modem. My modem serial number starts with a letter "T" so it's one of the newer ones capable of running on a 3G network. My LincolnWay app won't work unless I manually reset the modem then it connects and works fine for Lock, Unlock, Start, etc. When I park in my garage (metal building) at night it loses cell signal and will not reconnect on its own. I reach under the console where the TCU module is, unplug it and plug it back in and everything is fine until I park inside again. Lincoln tech support said my firmware is on 1.3.0 and needs updated to 1.4.5. I can't find any release notes on 1.4.5 to see if it specifically resolves the reconnect issue. I believe this issue is related to the 2G networks being decommissioned and the modem has never been told to automatically go out and find a 3G network. A power cycle of the modem manually forces it to do that. I called my local dealer and they want $120 per hour to do a firmware update and will not give me a hard quote, they said it could take an hour or 3 hours. I really don't want to potentially spend $360 just to be able to use a cell phone app to unlock my doors. Is there an alternative to updating firmware or is there another work-around to this problem? Thank you
 

Administrator
Joined
473 Posts
You are kind of stuck. I did the update with forscan but you have to get a special adapter and permission to download the software. There are a few of us with 2.4 forscan and the obdlink ex adapter. There is a lot of risk with a self flash. But it does sound like a firmware issue
 

Registered
Joined
7 Posts
Discussion Starter · #3 ·
That's what I was afraid of. I'll keep checking around with different dealers to see if I can get a quote. Do you know where I could find the release notes for the firmware versions to see what the changes are?
 

Administrator
Joined
473 Posts
Screenshot (18).png


This is the best I could find
 

Registered
Joined
7 Posts
Discussion Starter · #5 ·
Thank you @copbait . Do you think that firmware update 1.4.5 applies to the APIM or the TCU module? I've been experiencing strange steering wheel button controls too that may also be a firmware issue. Sometimes my cruise control buttons are non-responsive and when that happens the directional buttons on the left side of the steering wheel will not correspond to the button that was pushed, ie pushing the left button actually scrolls up, etc. Once things seem to "clear up" everything works fine. I have 67K miles on it so I'm not suspecting a clock spring or button issue. I'm hoping the firmware update may fix this as well.
 

Administrator
Joined
473 Posts
I think it is just the TCU update. I have been told by a friend of mine that is a FMC tech, if you start a firmware update for any module in IDS (ford's scan software) it will require the tech to update all modules with a new strategy (if available) before disconnecting the scanner. So maybe you will get a few modules updated.
 
1 - 6 of 6 Posts
Top