Lincoln MKC Forum banner
1 - 8 of 8 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 · (Edited)
The issues started 2-3 months ago, car would run rough at idle, stalling out at times, random check engine light and wrench light would go on when it would act up. Car self diagnosis always came back clean and the dealer said no codes were showing in the system. They said they had trouble replicating the issue.

Got the car back after 3-4 days and it never really went away, only got worse over time. Brought it back into the dealer a little over 3 weeks ago and had them sit in the car with me for a sec, really rough at idle.

They've now had my car for 3+ weeks and have confirmed it's a misfiring 2nd cylinder, but everything they try isn't fixing it (cylinder head, spark plugs, checked for carbon scaling, among a handful of other part changes). He said they are somewhat out of options short of a full engine replacement at this time and have been working directly with Lincoln.

He said at this point they may either do a short block replacement or a full engine replacement (he said the full replacement would actually be easier).

I will say, the dealer has been great keeping me informed of the progress (calling every 2-3 days) and is very apologetic, but I kinda just want my car back already or for them to make this right.

Anyone ever run into this before? Looks like I got a lemon unfortunately :(




Sent from my iPhone using Tapatalk
 

Registered
Joined
733 Posts
Which engine 2.0 or 2.3?
 
  • Like
Reactions: aphex

Registered
Joined
239 Posts
Aphex, my 2.3 needed an engine replacement at around 12K because they discovered an incorrect cylinder bore. They did a full replacement and it's been fine (16K on the vehicle now). I wouldn't worry about it, especially if the dealer's service is working with Lincoln on it and being thorough and transparent in communicating everything with you.
 

Registered
Joined
45 Posts
Carbon Build up is common on the 2.0EB engines. There's a YouTube video of a Ford tech talking about the carbon valve build-up issue on the 2.0. The symptoms you described are inline with his comments.

 

Registered
Joined
733 Posts
My direct injected Cadillac CTS use to load up a bit - About every 3 months I would take out on the highway and do an Italian tune-up - Essentially drive it hard through several gears and watch the black smoke pour out behind you.
 

Registered
Joined
1 Posts
The issues started 2-3 months ago, car would run rough at idle, stalling out at times, random check engine light and wrench light would go on when it would act up. Car self diagnosis always came back clean and the dealer said no codes were showing in the system. They said they had trouble replicating the issue.

Got the car back after 3-4 days and it never really went away, only got worse over time. Brought it back into the dealer a little over 3 weeks ago and had them sit in the car with me for a sec, really rough at idle.

They've now had my car for 3+ weeks and have confirmed it's a misfiring 2nd cylinder, but everything they try isn't fixing it (cylinder head, spark plugs, checked for carbon scaling, among a handful of other part changes). He said they are somewhat out of options short of a full engine replacement at this time and have been working directly with Lincoln.

He said at this point they may either do a short block replacement or a full engine replacement (he said the full replacement would actually be easier).

I will say, the dealer has been great keeping me informed of the progress (calling every 2-3 days) and is very apologetic, but I kinda just want my car back already or for them to make this right.

Anyone ever run into this before? Looks like I got a lemon unfortunately :(




Sent from my iPhone using Tapatalk
My newish 2019 33k Miles on it, only city miles, never drive it fast or crazy. Put nice custom wheels on it, my check engine light came on, then went off, then one day it got hot 馃敟 sitting at idle in the morning, then I'm a blink the temp went normal, took it to the dealer (warranty) it needed a new engine. 5 days at the shop. Fixed.
Cyclinder 1 had coolant init. Tech said he's been seeing more of this lately.
Now my check engine light comes on when I go 75-80mph then shuts off when I slow down in the city. Love this car. Strange issues.
 

Administrator
Joined
655 Posts
Ya unfortunately there is a really terrible design flaw in the motor. Does the check engine light flash when it comes on? If so that is a misfire and needs to be investigated quickly.
 
1 - 8 of 8 Posts
Top