Lincoln MKC Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone,




I am having an issue with my Welcome Lighting. I bought the vehicle last week. Worked perfect for a few days and now only works periodically. I have changed nothing with the settings.




This morning I turned off the Welcome Lighting in the options panel, locked the doors, walked away. Few minutes later returned, turned the Welcome Lighting back on in the options menu, locked doors and walked away. Returned to the car a few minutes later and it was working again. Not positive I fixed the issue but maybe I am missing something here.


Anyone else have this problem? Any helpful hints would greatly be appreciated.
 

·
Registered
Joined
·
24 Posts
Hello everyone,




I am having an issue with my Welcome Lighting. I bought the vehicle last week. Worked perfect for a few days and now only works periodically. I have changed nothing with the settings.




This morning I turned off the Welcome Lighting in the options panel, locked the doors, walked away. Few minutes later returned, turned the Welcome Lighting back on in the options menu, locked doors and walked away. Returned to the car a few minutes later and it was working again. Not positive I fixed the issue but maybe I am missing something here.


Anyone else have this problem? Any helpful hints would greatly be appreciated.
When you leave the vehicle, the doors must be locked last. If you open and close the rear liftgate after the doors have been locked the welcome lighting and mat will not work the next time you approach your MKC. It's a quirk in the design. Doors have to be locked last (after the liftgate is opened and closed, if applicable). Try it. Should work.
 

·
Registered
Joined
·
263 Posts
Most of the early production vehicles had this problem...there is a service bulletin and process your dealer can apply to fix the problem, if it continues for your vehicle. Mine was built in July and needed this update. Has worked perfectly since. Day or night.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for the replies. I called my dealer today and waiting for a call back in regards to anything they can do to the vehicle to correct this issue.


The good news is ever since I turned the welcome lighting off then back on in the settings it has been acting correctly. Sometimes it takes a real close approach to the vehicle for it to illuminate but at this point I'm happy it's working.
 

·
Registered
Joined
·
214 Posts
Most of the early production vehicles had this problem...there is a service bulletin and process your dealer can apply to fix the problem, if it continues for your vehicle. Mine was built in July and needed this update. Has worked perfectly since. Day or night.
Can you go out and put something in or take something out of the liftgate and not have problems?.
 

·
Registered
Joined
·
214 Posts
We purchased our MKC on 2/21 and noticed in the last couple of days that our welcome lighting wasn't working.

I went out and checked the welcome lights setting and it was on, so I turned it off and then turned it back on and it started working again, but as previously stated the approach has to be a lot closer now than it used to be.

We do not have an early production vehicle. The date on the window sticker is 11/20/14.

I am going to email our dealership to let them know we had the problem, just as a heads up. I might also ask about the service bulletin and ask if having it done will prevent it from failing in the future.
 

·
Registered
Joined
·
214 Posts
I did email our customer service contact at the dealership, but I did not mention the service bulletin as I wanted to see if he would mention it.

He didn't. He said, "If you're having trouble with your welcome lighting, we would like to repair it for you." He also said that the welcome lighting should come on automatically when you're within 10 ft. of the car. It should come on within 15 yards when you unlock the car using the key fob button.

I'm sure that the other night it did not come on from 10 ft. away, but we're going to re-check it tonight. We probably won't get to the dealership to have it fixed until next month as they are not close by.
 

·
Registered
Joined
·
214 Posts
Most of the early production vehicles had this problem...there is a service bulletin and process your dealer can apply to fix the problem, if it continues for your vehicle. Mine was built in July and needed this update. Has worked perfectly since. Day or night.
Went to the dealership to have them check out the Welcome Lighting and they reported that it is working fine. Yes, it is working because we reset it when it failed.

Do you know whether the TSB is supposed to prevent the failure or does it just have the Lincoln tech do a reset?

The build date on our MKC is 11/20/14 so it is not an early production vehicle.
 

·
Registered
Joined
·
263 Posts
My MKC welcome lighting issue was always from the start, since I got the car in August. The TSB applied by the service technician fixed it, and I don't think turning the feature on/off on the dash will keep the problem from coming back. The TSB needs to be applied. So check it from now on, and if it fails even once, you probably need to get specific about the TSB with your dealer, and best to take it there when it is not working. If intermittent let them know that. Mine wasn't...didn't work at all. Should work day or night, from "about' 10 feet out, as long as the car is LOCKED.
 

·
Registered
Joined
·
11 Posts
Hello everyone,




I am having an issue with my Welcome Lighting. I bought the vehicle last week. Worked perfect for a few days and now only works periodically. I have changed nothing with the settings.




This morning I turned off the Welcome Lighting in the options panel, locked the doors, walked away. Few minutes later returned, turned the Welcome Lighting back on in the options menu, locked doors and walked away. Returned to the car a few minutes later and it was working again. Not positive I fixed the issue but maybe I am missing something here.


Anyone else have this problem? Any helpful hints would greatly be appreciated.
There is a TSB to address this problem. Dealer will reflash the lighting control module.
 

·
Registered
Joined
·
214 Posts
My MKC welcome lighting issue was always from the start, since I got the car in August. The TSB applied by the service technician fixed it, and I don't think turning the feature on/off on the dash will keep the problem from coming back. The TSB needs to be applied. So check it from now on, and if it fails even once, you probably need to get specific about the TSB with your dealer, and best to take it there when it is not working. If intermittent let them know that. Mine wasn't...didn't work at all. Should work day or night, from "about' 10 feet out, as long as the car is LOCKED.
Thanks

Ever since ours failed, the welcome lighting does not come on until we're about 3-4 ft. from the front or the back of the car. I know how to make it fail - go out to the car and open and close the liftgate.

I doubt we'll be going back to our dealership for anything. It is a 70-mile round trip in congested metro traffic. There is a Ford dealership about 15 miles away and it's a much easier drive. I called them and they said that they would service our MKC.

I think the next time it fails, we'll give them a call and I'll mention the TSB. I am praying that they're a good dealership as far as their service department is concerned.
 

·
Registered
Joined
·
263 Posts
When approaching my LOCKED MKC in the garage, by the time I open the garage door from the house the Welcome Lighting is already on, and the car is parked on the further side of the garage...so about 10 feet +/-. Now never fails. But with car locked, and open/close the hatch, go back into house, wait some time for everything to be stable, go back and approach, and the Welcome Lighting does NOT come on. I believe this is the design. If I then un-lock/re-lock the car, or leave it locked, leave, go back after a few minutes, the Welcome Lighting comes on as it should.
 

·
Registered
Joined
·
214 Posts
When approaching my LOCKED MKC in the garage, by the time I open the garage door from the house the Welcome Lighting is already on, and the car is parked on the further side of the garage...so about 10 feet +/-. Now never fails. But with car locked, and open/close the hatch, go back into house, wait some time for everything to be stable, go back and approach, and the Welcome Lighting does NOT come on. I believe this is the design. If I then un-lock/re-lock the car, or leave it locked, leave, go back after a few minutes, the Welcome Lighting comes on as it should.
Thanks so much for the detailed information. Our first failure has dramatically decreased the distance before our Welcome Lighting is activated. When I open our garage door, I have to take one step into the garage before the Welcome Lighting comes on; and the car is parked right in front of me. In the dealership's measurement, they included the length from the back of the car to the welcome mat lights in their 10'. I was pretty sure that wasn't right, but they claimed they were working just fine. It was a pretty good indication to me of the type of service we'd be getting from them which is why I called the Ford dealership that is much more convenient for us to see if they would service our MKC. As a matter of fact, we called that dealership to confirm that they didn't sell Lincolns before we went to the other dealership.

It's not that the welcome lighting is a HUGE problem, but for the money we paid for the car, they should work properly.

We have a case number for the Sirius radio issue. When Lincoln comes out with a TSB for that, we'll take it into the Ford dealership and ask that the TSB fix for the Welcome Lighting be done at the same time.

Thanks again for taking the time to post and for giving me confirmation.
 

·
Registered
Joined
·
3 Posts
my mother is having a problem with her welcome lights...........how do you turn them on/off? Since I don't have the vehicle or the manual........trying to find the fix for her
 

·
Registered
Joined
·
214 Posts
my mother is having a problem with her welcome lights...........how do you turn them on/off? Since I don't have the vehicle or the manual........trying to find the fix for her
If our car was here, I could go retrace the steps of what I did to get it working again and post it for you, but our car is at the Ford dealer for the Sirius radio TSB.
 

·
Premium Member
Joined
·
163 Posts
my mother is having a problem with her welcome lights...........how do you turn them on/off? Since I don't have the vehicle or the manual........trying to find the fix for her
From the MKC 2015 Manual Page 72… :nerd

This feature lights select exterior lighting as you approach your vehicle. You must have an intelligent access key with you. The feature turns off when you open a door, liftgate, or unlock your vehicle.

Welcome lighting remains on for 25 seconds or until you start your vehicle.

The feature is active when:
• The feature is configured on in the information display. See General Information (page 112).
• The ignition is off.
• All doors and the liftgate are closed.
• You lock your vehicle.

The feature is not active when:
• Your vehicle detects the intelligent access key is inside.
• The intelligent access key is in close range of the vehicle for more than two minutes.
• The anti-theft alarm triggers.
• You do not start your vehicle for more than five days.
• The vehicle battery charge is low.

Note: When you disable this feature, you must switch the ignition on to reset it.

On Page 112 referenced above begins the guide for the informational Display Controls. That is a multipage explanation of the menu system. The menu system is accessed using the OK and Arrow Buttons on the left side of the steering wheel. In the menus, it boils down to…

Select Settings (Use buttons to move - Press OK to select)

Then Select Vehicle in the sub-menu that comes up

Then Select Lighting in the sub-menu that comes up

Several choices pop up, toward the bottom you will see Welcome Lighting with a little Box beside it. If there is a check in the box, it is activated. If not, scroll down to it and press OK – the check should appear and it is activated.
 
1 - 17 of 17 Posts
Top